Back to overview
Resolved

Investigating Dashboard Load Issues

Sep 10, 2026 at 12:28pm UTC
Affected services
DASHBOARD
TAGGRS API

Resolved
Sep 10, 2026 at 12:47pm UTC

Resolved: Dashboard Load Issues

The issue causing slow load times and error messages on the main dashboard has been fully resolved. All dashboard features and data displays are now back to operating normally.

We apologize for the inconvenience and appreciate your patience while our team worked to restore full performance.

Created
Sep 10, 2026 at 12:28pm UTC

We are currently responding to an issue causing slow load times and timeout errors on the main dashboard. As a result, some users may see error messages or experience delays when trying to view their data.

Please be assured that tracking is not impacted by this issue.

Our engineering team is actively working to resolve the problem and restore full performance. We apologize for the inconvenience and will post another update as soon as we have more information.