Back to overview
Degraded

Investigating: Dashboard Loading Issues

Jun 9, 2026 at 10:11am UTC
Affected services
DASHBOARD

Resolved
Jun 9, 2026 at 10:15am UTC

Resolved: Dashboard Loading Issues
The issue preventing the dashboard from loading has been fully resolved, and all systems are now operating normally. We apologize for any disruption this may have caused.

Created
Jun 9, 2026 at 10:11am UTC

We are currently experiencing an issue where the dashboard is failing to load. Our engineering team is actively investigating the root cause and working to restore full functionality as quickly as possible. We will provide an update once the issue is resolved.

Tracking is not affected.